Alice Community  

Go Back   Alice Community > Alice 2 > Bugs and Troubleshooting

Reply
 
Thread Tools Display Modes
Bug in 3.0.0.2.9 on linux?: UNABLE TO LOAD OPENGL
Old
lmorillas
Guest
 
Status:
Posts: n/a
Default Bug in 3.0.0.2.9 on linux?: UNABLE TO LOAD OPENGL - 09-20-2010, 07:52 AM

Is something wrong with the recently released linux installer?

I've installed new 3.0.0.2.9 on Ubuntu 10.04. When I start Alice, it raises this error:


version: 3.0.0.2.9
comboBoxUI: javax.swing.plaf.synth.SynthComboBoxUI@1efc208
comboBoxUI: javax.swing.plaf.synth.SynthComboBoxUI@1898115
setLocale en_US
java.util.Locale.getDefault() es_ES
javax.swing.JComponent.getDefaultLocale() es_ES
platform: Linux-i386
library path: /home/lm/Alice3Beta/application/linux-i586

UNABLE TO LOAD OPENGL
------ -- ---- ------
The most common reason for this is an incorrectly set Java library path. Please update your VM arguments.
The text below has been copied to the clipboard for your convenience.
Linux-i386

all properties
--- ----------
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
<properties>
<comment>comment</comment>
<entry key="java.runtime.name">Java(TM) SE Runtime Environment</entry>
<entry key="sun.boot.library.path">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/i386</entry>
<entry key="java.vm.version">16.3-b01</entry>
<entry key="java.vm.vendor">Sun Microsystems Inc.</entry>
<entry key="java.vendor.url">http://java.sun.com/</entry>
<entry key="path.separator">:</entry>
<entry key="java.vm.name">Java HotSpot(TM) Server VM</entry>
<entry key="file.encoding.pkg">sun.io</entry>
<entry key="sun.java.launcher">SUN_STANDARD</entry>
<entry key="user.country">ES</entry>
<entry key="sun.os.patch.level">unknown</entry>
<entry key="java.vm.specification.name">Java Virtual Machine Specification</entry>
<entry key="user.dir">/home/lm/Alice3Beta</entry>
<entry key="java.runtime.version">1.6.0_20-b02</entry>
<entry key="java.awt.graphicsenv">sun.awt.X11GraphicsEnvi ronment</entry>
<entry key="java.endorsed.dirs">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/endorsed</entry>
<entry key="os.arch">i386</entry>
<entry key="java.io.tmpdir">/tmp</entry>
<entry key="line.separator">
</entry>
<entry key="java.vm.specification.vendor">Sun Microsystems Inc.</entry>
<entry key="os.name">Linux</entry>
<entry key="sun.jnu.encoding">UTF-8</entry>
<entry key="java.library.path">/home/lm/Alice3Beta/application/linux-i586</entry>
<entry key="java.specification.name">Java Platform API Specification</entry>
<entry key="java.class.version">50.0</entry>
<entry key="sun.management.compiler">HotSpot Tiered Compilers</entry>
<entry key="os.version">2.6.32-24-generic-pae</entry>
<entry key="user.home">/home/lm</entry>
<entry key="user.timezone"/>
<entry key="java.awt.printerjob">sun.print.PSPrinterJob</entry>
<entry key="file.encoding">UTF-8</entry>
<entry key="java.specification.version">1.6</entry>
<entry key="java.class.path">/home/lm/Alice3Beta/ext/apple/AppleJavaExtensions.jar:/home/lm/Alice3Beta/ext/mail/lib/smtp.jar:/home/lm/Alice3Beta/ext/mail/lib/dsn.jar:/home/lm/Alice3Beta/ext/mail/lib/mailapi.jar:/home/lm/Alice3Beta/ext/mail/lib/pop3.jar:/home/lm/Alice3Beta/ext/mail/lib/imap.jar:/home/lm/Alice3Beta/ext/mail/mail.jar:/home/lm/Alice3Beta/ext/jira/jira-soapclient-4.0-with-dependencies.jar:/home/lm/Alice3Beta/ext/youtube/google-collect-1.0-rc1.jar:/home/lm/Alice3Beta/ext/youtube/youtube.jar:/home/lm/Alice3Beta/ext/jaf/activation.jar:/home/lm/Alice3Beta/ext/modified_nimbus/modified_nimbus.jar:/home/lm/Alice3Beta/ext/wrapped_flow_layout/wrapped_flow_layout.jar:/home/lm/Alice3Beta/ext/rpc/xmlrpc-client-1.1.jar:/home/lm/Alice3Beta/ext/jmfmp3/lib/ext/mp3plugin.jar:/home/lm/Alice3Beta/ext/swingworker/swing-worker-1.2.jar:/home/lm/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/customizer.jar:/home/lm/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/jmf.jar:/home/lm/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/multiplayer.jar:/home/lm/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/mediaplayer.jar:/home/lm/Alice3Beta/ext/jogl/lib/gluegen-rt.jar:/home/lm/Alice3Beta/ext/jogl/lib/jogl.jar:/home/lm/Alice3Beta/gallery/mtwtGalleryBoxes.jar:/home/lm/Alice3Beta/gallery/mtwtGalleryLargeIcons.jar:/home/lm/Alice3Beta/gallery/stagePersonEditorLargeIcons.jar:/home/lm/Alice3Beta/lib/3.0.0.2.9/alicecore.jar</entry>
<entry key="user.name">lm</entry>
<entry key="org.alice.ide.IDE.install.dir">/home/lm/Alice3Beta</entry>
<entry key="java.vm.specification.version">1.0</entry>
<entry key="java.home">/usr/lib/jvm/java-6-sun-1.6.0.20/jre</entry>
<entry key="sun.arch.data.model">32</entry>
<entry key="user.language">es</entry>
<entry key="java.specification.vendor">Sun Microsystems Inc.</entry>
<entry key="java.vm.info">mixed mode</entry>
<entry key="java.version">1.6.0_20</entry>
<entry key="java.ext.dirs">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/ext:/usr/java/packages/lib/ext</entry>
<entry key="sun.boot.class.path">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/resources.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/rt.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/jsse.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/jce.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/charsets.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/classes</entry>
<entry key="java.vendor">Sun Microsystems Inc.</entry>
<entry key="swing.aatext">true</entry>
<entry key="file.separator">/</entry>
<entry key="java.vendor.url.bug">http://java.sun.com/cgi-bin/bugreport.cgi</entry>
<entry key="sun.io.unicode.encoding">UnicodeLittle</entry>
<entry key="sun.cpu.endian">little</entry>
<entry key="sun.desktop">gnome</entry>
<entry key="sun.cpu.isalist"/>
</properties>
   
Reply With Quote
Old
SlithyToves
Member
 
SlithyToves's Avatar
 
Status: Offline
Posts: 20
Join Date: Sep 2010
Location: USA
Default 09-20-2010, 10:34 AM

MiR was having the same problem on Ubuntu 9.10. You might want to look at this thread: http://www.alice.org/community/showp...6&postcount=11 Apparently, the so libraries were not copied correctly.

Hope this helps!


SlithyToves

"Twas brillig, and the slithy toves
Did gyre and gimble in the wabe"
   
Reply With Quote
3.0.0.2.9 on Ubuntu 9.10 (solved)
Old
sm8ps
Guest
 
Status:
Posts: n/a
Default 3.0.0.2.9 on Ubuntu 9.10 (solved) - 09-24-2010, 07:08 AM

Hello fellow Ubuntu/Linux users!
I encountered the problem described above and resolved it the following way:

1. installed jogl-java with all dependencies from synaptics

2. modified /usr/local/Alice3Beta/alice.sh by adding
-Djava.library.path="/usr/lib/jni/"
after the already present
-Djava.library.path="/usr/local/Alice3Beta/application/linux-i586"

As far as I can tell just now, this solved the problem. Alice starts neatly, only spitting out some ToDos and warnings. I have not tested its actual functionality yet because I am trying to learn just that.

Cheers!
St. Mueller, Switzerland
   
Reply With Quote
3.0.0.2.9 on Ubuntu 9.10 (solved) also on 10.4
Old
sm8ps
Guest
 
Status:
Posts: n/a
Default 3.0.0.2.9 on Ubuntu 9.10 (solved) also on 10.4 - 10-02-2010, 05:34 PM

The same remedy worked on Ubuntu 10.4. To be more precise, step 2 should read:

2. In /usr/local/Alice3Beta/alice.sh,
change -Djava.library.path="/usr/local/Alice3Beta/application/linux-i586"
to -Djava.library.path="/usr/local/Alice3Beta/application/linux-i586:/usr/lib/jni"

Cheers!
Stefan Mueller, Switzerland
   
Reply With Quote
Old
rainbox
Guest
 
Status:
Posts: n/a
Default 11-03-2010, 06:36 AM

Quote:
Originally Posted by sm8ps View Post
The same remedy worked on Ubuntu 10.4. To be more precise, step 2 should read:

2. In /usr/local/Alice3Beta/alice.sh,
change -Djava.library.path="/usr/local/Alice3Beta/application/linux-i586"
to -Djava.library.path="/usr/local/Alice3Beta/application/linux-i586:/usr/lib/jni"

Cheers!
Stefan Mueller, Switzerland
Thanks, this works on ubuntu 10.10 too
   
Reply With Quote
Old
velixzeen
Guest
 
Status:
Posts: n/a
Default 11-21-2010, 09:45 PM

Works for debian sid and lenny too. Thanks for posting
   
Reply With Quote
Old
SimonJonesHS
Junior Member
 
Status: Offline
Posts: 2
Join Date: Mar 2012
Location: AU
Default 03-05-2012, 10:59 PM

Thanks for the tips guys, was facing the exact same problem on my Ubuntu 10.04 and with your help managed to resolve it. Now I am going to think twice about any plans of upgrading my OS in case it faces any problems again.

Simon - Harboursat
   
Reply With Quote
Reply

Tags
opengl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2021, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.