Alice Community  

Go Back   Alice Community > Alice 2 > Bugs and Troubleshooting

Reply
 
Thread Tools Display Modes
Tutorial 4: "Error changing gallery viewer...
Old
kmschinkoeth
Guest
 
Status:
Posts: n/a
Default Tutorial 4: "Error changing gallery viewer... - 04-26-2009, 09:48 AM

...to Home\Local Gallery"

I get this error message after loading my new world (File->New World, then selecting the grass template) and clicking on the "Add Objects" button to expand the 3D world.

Immediately, that error message pops up, in repetition until Alice crashes.

Any ideas?

Thanks! ~k.

FYI: I have Alice 2.2 installed in my Applications folder in OS X. This shouldn't have been installed to the Home folder, should it? Is there a fix so I can leave it in my Applications folder?
   
Reply With Quote
Old
HisWorld
Guest
 
Status:
Posts: n/a
Default 04-27-2009, 07:07 AM

I'm not an expert at mac operating systems, but i though OS X didnt have any such limitations. Have you tried using the "required/ifAlicefailstrythis.exe" ?
   
Reply With Quote
Old
poetnabotl
Guest
 
Status:
Posts: n/a
Default 05-01-2009, 09:36 PM

Same problem. Suggestions, anyone?
   
Reply With Quote
Old
DrJim
Guest
 
Status:
Posts: n/a
Default 05-03-2009, 12:34 PM

Quote:
Originally Posted by kmschinkoeth View Post
This shouldn't have been installed to the Home folder, should it? Is there a fix so I can leave it in my Applications folder?
Not a Mac guy myself, but I suspect this is the problem. On a PC, the .exe file and the Library files have to be in the same folder for the default installation. You may be able to change this - for 2.2 on a PC - I know you can relocate some of the files in that version. If so, the instructions are in a file that is part of the download. Check there to see if you can also do that for a Mac.

Last edited by DrJim; 05-03-2009 at 12:40 PM. Reason: Edited second paragraph.
   
Reply With Quote
Any Luck
Old
Gail McDougall
Guest
 
Status:
Posts: n/a
Default Any Luck - 07-18-2009, 06:34 AM

Have you had any luck fixing this problem. I have the same problem.
   
Reply With Quote
Same problem here
Old
kdavidson
Guest
 
Status:
Posts: n/a
Default Same problem here - 07-22-2009, 11:29 AM

I get the same thing with Tutorial 4 (running on Mac OS X 10.5.7).

Strange that just using Alice without running the Tutorial I can add objects to worlds without any problems - either from local or web based directory.

The (multiple) error dialogues displayed contain "Error changing gallery viewer to Home\Local Gallery" but I cannot click on the More Details button -- before the Mac OS closes the Alice application.

Is there any log files that I can send to see more information regarding the error to help debug this problem?

I have installed Alice in a subdirectory of /Applications/_dev/Alice and I can see there is a .alice2 directory under my home directory containing all the objects for the worlds.

I have since tried running the Alice application from my home directory or via an alias in my home directory - same result as before.

Last edited by kdavidson; 07-22-2009 at 11:38 AM. Reason: updated with further notes
   
Reply With Quote
Same Issue
Old
sabrams
Guest
 
Status:
Posts: n/a
Default Same Issue - 12-09-2009, 09:15 AM

Folks,

I have the same issue, on a new iMac - 3.08ghz - 27" monitor - 8 gigs RAM - running Snow Leopard. A little distressing, since we're supposed to use this software for school. Does this issue render the program useless?

Steve
   
Reply With Quote
Just another Mac user having this problem
Old
bdolge
Guest
 
Status:
Posts: n/a
Default Just another Mac user having this problem - 01-17-2010, 03:28 AM

The program works fine but the tutorial locks up. Any solutions?
Specs: Mac OS X 10.5.8, 1.83 GHz core Duo, 512 MB RAM, 798 GB avail on HD,
Alice 2.2 running from Users/~/desktop/Alice2.2, me and everyone have read/write perrmission
   
Reply With Quote
Tutorial 4: Error changing gallery viewer . . .
Old
gmkomar
Guest
 
Status:
Posts: n/a
Unhappy Tutorial 4: Error changing gallery viewer . . . - 02-17-2010, 09:21 PM

I am running Mac OS X 10.4.11 and get the same error going from page 14 to page 15. The error repeatedly pops up at a rapid rate, so I cannot even close it. The whole computer freezes and I have to force shut down to get out of it. Has anyone figured out how to fix this? I would really like my students to use this particular tutorial.

Thanks for any assistance.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2020, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.