Thread: File I/O Tool
View Single Post
Senior Member
DensetsuNoKaboom's Avatar
Status: Offline
Posts: 1,188
Join Date: May 2010
Location: e4eaf2
Default 06-16-2011, 05:59 PM

Originally Posted by arty-fishL View Post
I worked out what was wrong, its fixed.
Its updated and definitely works now, I tested it on a non-modified Alice.
Error during simulation.

Alice version: 2.2 02/10/2011

Throwable that caused the error:

Traceback (innermost last):

File " rty[name=script,owner=edu.cmu.cs.stage3.alice.core.res ponse.ScriptResponse[world.iOTool.write_line.__Unnamed0__]]", line 1, in ?

File "<string>", line 153, in writeline

IndexError: index out of range: -1


At least this time, it didn't happen until I tried to write a variable to line 1.
EDIT: And hey, it works when I overwrite the entire file with text rather than one line! And it works when I load that file!
EDIT2: And this is my 600th post!

Thank you for taking the time to read this signature. This signature loves you.

Last edited by DensetsuNoKaboom; 06-17-2011 at 06:46 AM.
Reply With Quote