Alice Community

Alice Community (
-   Bugs and Troubleshooting (
-   -   "Catastrohpic" Alice errors (

itrickski 11-09-2006 03:51 PM

"Catastrohpic" Alice errors
Hi, I am teaching Alice, and have the program loaded on a laptop to use for demo purposes in the classroom. for the last 8 weeks, everything has worked perfectly. Early this week, i created a fairly simple world, and when i opened it again to demo to the class, it gave a "general error" for any and all commands.

Now i can no longer run any worlds (new or saved). I can "add objects" but that is all. I have uninstalled alice, removed any references from registry (manually), defragged the hard drive, and reinstalled alice. I still can do nothing more in any alice world (new or saved) than "add objects".

I don't understand why a complete uninstall of the software would not fix the problem. Has this happened to anyone else? does anyone else have suggestions?

Puzzled in TN!:confused:

Shadow Sovereign 11-09-2006 07:02 PM

Wow, that's huge...
I've never heard of such an instance before...:confused: ... for ANY program. But perhaps the problem is rooted deeper than it seems.

You said you tried removing any program referrences manually? Have you tried deleting any relevant files from your C:/Program Files directory as well? I know this sounds stupid of me to ask, but I'm just intrigued. :rolleyes:

Another possibility maybe that, somehow, your alice directory may have been moved, and alice is still looking for it in the old place. If that is the case, you may want to check where the directory is and reset the defaults to accommodate the new location.

Be careful... it would really suck if you had to completely reformat your entire C Drive, because that means a total system wipes. The last time I did that, I lost a massive amount of my files... some of which I really would've liked to keep! :o

lanceA 11-09-2006 08:51 PM

I was unaware that ALICE made [B][U]any[/U][/B] entries into the WINDOWS registry. Can you share with us what KEY values these are written to?


DrJim 11-09-2006 10:48 PM

Scary - though Halloween was over.
Almost sounds like a hardware crash. Three quick questions (I apologize in advance :o for asking the obvious):

Was only Alice affected or do other programs on the laptop also have problems?

Will the copy of Alice you reloaded onto the laptop load correctly on any other hardware?

Did you try reinstalling the Java runtime environment?

gabe 11-09-2006 11:17 PM

Alice does not install anything into the registry. If anything was found, it was most likely a reference to most recent documents or some form of history. Try unzipping Alice to a different directory or running Alice off of a USB flash drive or CD-R. I'm curious to know if that does anything. I will ask the team tomorrow if they have any idea how something like this could have happened and any possible solution.

itrickski 11-11-2006 03:37 PM

Things to try
yes, have installed Alice from website and from CD successfully on other machines. laptop seems to be fine with other apps, only Alice acts up. will try the following...thanks for the good suggestions
- uninstall and reinstall Java
- reinstall alice to a different directory

was wondering if Alice made use of any windows files that might have gotten hosed somehow.

itrickski 11-19-2006 01:02 PM

slow and Steady is saving grace
well, i uninstalled and re-installed everything, including all the Java components. Normal Alice still won't do anything but let me "add objects". The good news is that "slow and steady" alice will run fine. Kind of strange, since the computer i've been using is only 3 months old, with a plethora of video and regular memory. anyhow, alls well that ends well. thanks for your input.

mich in tn

DrJim 11-19-2006 05:17 PM

One last gasp.
When I've had to go to slow and steady Alice (not often), it's generally been related to a video card problem. It's (remotely :o ) possible you may have installed some software that changed the settings or otherwise corrupted the driver - you might try reinstalling that.

The whole problem is still pretty scarry. :eek: Hope someone eventually figures out what went wrong.

All times are GMT -5. The time now is 08:04 PM.

Copyright ©2020, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.