Alice Community

Alice Community (
-   Bugs and Troubleshooting (
-   -   Alice crashes every other time (

zero00 05-12-2012 09:47 AM

Alice crashes every other time
For some reason, the 3/01/2012 version of Alice I'm using crashes every other time I run it. :confused:

The first time I run the program, it just gives me an error and crashes. Then I have to end the process in Task Manager.
The second time, it loads up quickly and with no problems.

x2495iiii 05-12-2012 01:34 PM

That happens to me too. Not sure why or how to fix it. Best thing I could recommend is delete and re-download Alice.

arty-fishL 05-12-2012 07:21 PM

Bizarre. I'm using that version, but this never happens to me.

aikmin 05-19-2012 01:10 AM

Can you post the error?

x2495iiii 05-21-2012 12:35 PM

Alice version: 2.2 03/01/2012 Windows 7

os.version: 6.1

os.arch: x86 Java HotSpot(TM) Client VM

java.vm.version: 20.0-b11

user.dir: C:\Users\Paul\Downloads\Alice2.2\Required

java.lang.IllegalArgumentException: component not found in tabbed pane

at javax.swing.JTabbedPane.setSelectedComponent(

at edu.cmu.cs.stage3.alice.authoringtool.dialog.StartUpContentPane.setTabID(

at edu.cmu.cs.stage3.alice.authoringtool.dialog.StartUpContentPane.guiInit(

at edu.cmu.cs.stage3.alice.authoringtool.dialog.StartUpContentPane.<init>(

at edu.cmu.cs.stage3.alice.authoringtool.AuthoringTool.dialogInit(

at edu.cmu.cs.stage3.alice.authoringtool.AuthoringTool.<init>(

at edu.cmu.cs.stage3.alice.authoringtool.JAlice.main(

BrennanWaddell 05-21-2012 01:31 PM

I get that too.

MrMoke 05-27-2012 07:22 PM

Me Too
Using Windows 7 64-bit, if that makes a difference. It leaves the splash screen on the desktop, and has to be killed with Task Manager.
It doesn't happen often; usually when I'm forcing an Alice re-boot after making a change.

MrMoke 06-18-2012 09:16 AM

Further testing today
[QUOTE=MrMoke;49083]Using Windows 7 64-bit, if that makes a difference. It leaves the splash screen on the desktop, and has to be killed with Task Manager.

Have tried several options including moving the newest Alice 2.2 folder into the Progrm Files (x86) folder in my Windows 7 64-bit workstation. The problem is strangely repeatable.
I can start and quit Alice 2.2 3/01/2012 as many times as I want with no problem, as long as I don't do anything. However, if I load a program before quitting, Alice will crash with the mentioned error the [U]next[/U] time I start it, and it must be killed via task Mgr.
The same error is also repeatable using slow and steady Alice 2.2.

Something done when loading an .a2w file makes the difference. The file doesn't have to be modified, nor saved. The thought occurred to me that it might be incompatibility between the newer version and older .a2w files, but creating a new world with just a bunny, saving it, quitting, and restarting Alice generated the same error.

All testing was done using original downloads with no modifications.:(

Update: Notice that Alice 2.2 required/jre folder is using jre1.6.0_25, while my system is currently running jre version 7_5.

Update 2: Tried using the current download on a classroom 64-bit CPU workstation with a 32-bit install of Windows 7. Exactly the same problem, so it is not isolated to 64-bit O/S.

aikmin 06-20-2012 06:04 AM

Start up window bug
The bug was caused by a failed initialization of the selected tab. The error will only occur if the "Open a world" tab was selected the last time Alice was opened. To temporary fix this problem, make sure you create a new world before you close Alice. That will then leave Alice with the "Template" tab selected before closing.

MrMoke 06-23-2012 11:19 AM

Please release a patch
My School district restricts Task Manager for student logins, and in some cases, teachers.
A students only recourse is to logoff and back on to clear the frozen program, which wastes time.

Will this get patched soon?

All times are GMT -5. The time now is 12:57 PM.

Copyright ©2020, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.