Alice Community

Alice Community (
-   Bugs and Troubleshooting (
-   -   Alice error on playback (

bonecandy 10-13-2006 09:54 PM

Alice error on playback
1 Attachment(s)
I'm getting really frustrated here. I've been creating a pretty elaborate Alice project for a while, and suddenly it stops working. When I click play, it immediately gives me two errors in a row: Error during simulation, and Error during playback. The annoying thing is that I have tried to debug it by deleting EVERYTHING in the world. I've deleted all my objects, all my code, everything. It STILL gives me an error. It only happens with this world. So I've come to question the world statistics. Under world statistics at the bottom of the program, "face count" is all in red. and gives me a number around 77,000. I think that's bad. However, when I start deleting things, it doesn't go down. Nor does the objects counter in the statistics. I would think my computer can handle it. It's pretty fast: PowerMac G5 with 1.5Gb of RAM.
Anyway, here is the error output:

Error during simulation.

Alice version: 2.0.7 Mac OS X
os.version: 10.4.8
os.arch: ppc Java HotSpot(TM) Client VM
java.vm.version: 1.4.2-54
user.dir: /Applications/

Throwable that caused the error:
at edu.cmu.cs.stage3.alice.core.Sandbox.scheduleBehaviors(
at edu.cmu.cs.stage3.alice.core.World.scheduleBehaviors(
at edu.cmu.cs.stage3.alice.core.World.schedule(
at edu.cmu.cs.stage3.alice.core.clock.DefaultClock.schedule(
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringTool$
at edu.cmu.cs.stage3.alice.authoringtool.util.DefaultScheduler.simulateOnce(
at java.awt.event.InvocationEvent.dispatch(
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.Dialog$
at java.awt.Component.setVisible(
at edu.cmu.cs.stage3.swing.DialogManager.showModalDialog(
at edu.cmu.cs.stage3.swing.DialogManager.showDialog(
at edu.cmu.cs.stage3.alice.authoringtool.Actions$15.actionPerformed(
at javax.swing.AbstractButton.fireActionPerformed(
at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(
at javax.swing.DefaultButtonModel.fireActionPerformed(
at javax.swing.DefaultButtonModel.setPressed(
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(
at java.awt.AWTEventMulticaster.mouseReleased(
at java.awt.Component.processMouseEvent(
at java.awt.Component.processEvent(
at java.awt.Container.processEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.LightweightDispatcher.retargetMouseEvent(
at java.awt.LightweightDispatcher.processMouseEvent(
at java.awt.LightweightDispatcher.dispatchEvent(
at java.awt.Container.dispatchEventImpl(
at java.awt.Window.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(

What could possibly be wrong?

Thanks for any help

Mr Nemo 10-13-2006 10:13 PM

You don't happen to have a predefined method with <None> as it's target would you? That's what usually causes that error for me.:confused:

bonecandy 10-13-2006 10:41 PM

Well, I'm trying check all my gazillion methods right now, but I get so many drag and drop errors sometimes too... but thanks for the tip, I'll see if that does anything. If anyone else has any ideas, please chime in :(

gabe 10-13-2006 10:48 PM

Could you attach your world for us to help troubleshoot?

DrJim 10-13-2006 11:18 PM

A possibility
I may just be sensitive to this because I tried to import a 16M object file (I overdid the subdivisions a bit on the mesh a bit :rolleyes: and wasn't really watching the resulting file size) this afternoon and it made Alice behave strangely until I completely stopped and rebooted the computer. I didn't get anything from Alice except "a problem was encountered displaying this object" and a "try again" or "quit" option - I should have quit before I did.

But anyway, what struck me was the large size of your texture files at nearly 27M. I went back and checked some old worlds and this is at least 5X what I've ever had. I've also had problems running worlds with one of the large environments from the gallery and with four or five objects - just don't think Alice can keep up, at least on my hardware - though the problem doesn't seem to be obviously hardware dependent.

Maybe you already know, but I'd check where the large texture number is coming from and/or delete things like any large environments. Another possibility is that you are using an uncompressed texture file that was generate with a high resolution - this can give problems and is not something you think of right away, since once you're in Alice, the details of the textures are pretty well hidden. (You can also have problems with large sound files, though that doesn't sound like the problem you're having.)

Good Luck. :)


bonecandy 10-13-2006 11:45 PM

Well it would appear you were correct DrJim. As soon as I started deleting objects it ran better. I did import a large picture file that I made in photoshop too. But it's only about 350kb, so I figure it shouldn't make too large a difference (it also adds a lot of pizzazz :p ). After deleting some objects and redundant methods and events, it runs again. I did, however, notice that even after I continued to delete more objects from the world, it had a very small impact on the texture sizes. So there's probably some obscure object I have in there that's making the texture sizes balloon so much.
The statistics are now:
object count: 803; down from 864
face count: 67,496; down from 72,907
texture memory: 24.5; down from 26.6

I think the world is rather large to upload; it's about 20mb. But I can upload if you guys want. So it would appear Alice has a lot of trouble running large worlds... hopefully this'll get fixed in the future patches.
It's strange though. I've had an Alice world that was over 34mb before and it never exhibited these problems.

Thanks for your help

gabe 10-14-2006 01:26 AM

You are correct, Alice does not handle very large (i.e. lots of objects, large texture maps, mp3s, etc.) very well. Having over 800 objects is *enormous* for an Alice world. If you have duplicate objects, have you tried using the copy object feature instead of dragging in another object from the gallery?

Alice 3.0 should have better support for large worlds.

DrJim 10-14-2006 01:15 PM

More Comments
A couple of more comments since my last guess seemed to be at least partially correct (I do the same thing at casino's, they love me :D ). I [B]would[/B] appreciate any feedback on these!

1. The multiple object issue is (primarily) not one of file size but of the number of calculations (in 3D and with arbitrary angles in Alice) that must be made for each "frame," i.e. each picture update. Without some clever tricks, this goes up as the factorial of the number of objects - which can get big! (4!=24, 8! is >40K, 12!=5E+8, 16!=2E+13) :eek:

Needless to say, nearly all movement calculation methods use compression algorithms that do rough, multiple frame calculations and don't update things that don't appear to move. (Doesn't always work well - look at fast moving pictures on your cell phone.) Gabe mentioned using copies (good hint, I didn't know that :) ); also try "move to" commands rather than incremental moves. (Question for Gabe to ask the developers - does making an object "not seen" also remove it from the position calculations? At first glance this doesn't seem to help.)

2. Usually (NOT always) it's [B]not[/B] the [B]total[/B] file size that is really critical - but the size of the individual files, which determine the number of times one must go to secondary (slow) memory. (I'm told, and have no reason to doubt, that Alice (and Java) also have a memory "leak" problem although I'm not completely sure what that means. Something about the "destructor" not working right - or maybe that was Star Wars. :rolleyes: )

Finally, based on experience (going back to Mariner images), the problem will [B]never[/B] be "fixed." No matter what the hardware and software guys do, the customer/user will always want better resolution, higher quality images and more accurate motion. It's sure more fun being a user. :cool:


All times are GMT -5. The time now is 10:15 AM.

Copyright ©2020, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.